SMB Technical Support Department Outage
Incident Report for Avast and AVG Business
Resolved
This incident has been resolved.
Posted Apr 14, 2023 - 22:10 EDT
Update
We are continuing to investigate this issue.
Posted Apr 14, 2023 - 22:09 EDT
Investigating
We are currently experiencing an outage in the SMB Technical Support Department. Please be aware that we are unable to take your call or chat at this time. We are working on resolving this issue as fast as possible. Thank you for your patience!
Posted Apr 14, 2023 - 20:18 EDT