"Subscribe more devices" in the Avast/AVG Business Cloud Console returns an error
Incident Report for Avast and AVG Business
Resolved
This incident has been resolved.
Posted Nov 10, 2020 - 04:38 EST
Investigating
We are currently investigating the issue that is preventing "Subscribe more devices" connecting users to the shopping cart. If you need immediate assistance adding more devices, please contact our SMB support: https://www.avast.com/en-us/business/support/all-products
Posted Aug 27, 2020 - 17:18 EDT